跳到正文

ForceGL20

作者:kabanfriends

Forces the game to use OpenGL 2.0!

收藏

介绍

中文介绍正在准备中,下面暂时显示原文。

🚧 Updates Halted Indefinitely

As I can no longer locally test if the fix method used by this mod is still effective in newer Minecraft versions, the mod will be unsupported for the time being. You can still play Minecraft versions 1.17.x – 1.20.x using the latest version of ForceGL20, but the mod is not supported in any newer versions.

Possible alternatives for newer Minecraft releases:

Even though I am not personally working on the mod anymore, pull requests to the mod’s repository are still welcomed. I may come back to updating ForceGL20 in the future, and this section of the page will be removed when I decide to do so.

⚠️ Disclaimer

This mod only fixes GLFW error 65543; it will NOT work for any other error codes! If you are getting this message when you launch Minecraft, this mod may resolve your issue:
GLFW error 65543

With that said, please read the mod’s description below at least once, so that you understand why this mod may fix your issue with the game.

ForceGL20

ForceGL20 is a mod that allows running newer versions of Minecraft on old computers by forcing the game to use OpenGL 2.0.

Why?

Since Minecraft 1.17, the game’s required OpenGL version was updated from 2.0 to 3.2. However, some graphic cards on old computers do not support OpenGL 3.2, making the game unable to launch for some players.

This Minecraft mod lowers the required OpenGL version to 2.0, just like how it was prior to Minecraft 1.17. So, if your computer can play Minecraft 1.16 fine but has issues running Minecraft 1.17, this mod is for you.

But does it work?

There have been no major issues with forcing the game to run on older OpenGL. However, note that you are forcing the game to run in an unsupported way by installing this mod, so there might be unexpected issues with other mods or resource packs.

In addition, this mod would be useless if Minecraft starts using new OpenGL features that your computer can’t run in a future update. I will discontinue the support for this mod as soon as this band-aid solution stops working.

While you are free to use this mod to run newer versions of Minecraft, please do consider upgrading to a newer graphic card as soon as possible.

I found an issue!

Due to the statement above (that you are running the game in an unsupported way ), I cannot provide support for issues you may experience in this mod. This mod’s only purpose is to change the OpenGL version and it does not apply any other fixes to the game’s code.

It doesn’t work!

Please check that you are getting GLFW error 65543 (this exact number) when you launch the game. If that number differs even by 1, it is an entirely different error that’s out of this mod’s scope.

常见问题

ForceGL20 支持哪些 Minecraft 版本?

ForceGL20 支持 Minecraft Java 版 1.17–1.20.4,共 15 个版本,可用的加载器:Fabric / Forge。下载时注意选择和你游戏版本一致的文件。

ForceGL20 怎么安装?

先用 PCL2 或 HMCL 启动器安装对应版本的 Fabric / Forge,再把下载的 .jar 文件放进游戏目录的 mods 文件夹,重新启动游戏即可。开启了版本隔离的,mods 文件夹在 versions/版本名 下面。运行环境:仅客户端。

评论

登录后评论和评分

kabanfriends 的其他作品

查看全部 →